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Folder Management

Create a folder on desktop: 
HTML Exercises.

Copy files into folder.
Set Windows to show file extensions: 
Tools > Folder Options…, “View” tab, uncheck 
“hide extensions,” click button “Apply to All 
Folders.”
Save all work in the folder on desktop!
Copy files onto your disk/portable drive 
(or zip & email to yourself) before leaving!
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Working With a Browser

Open Explorer or Firefox web browser 
(or other browser).
Drag a shortcut to desktop, also 
bookmarks toolbar. 
View the page in browser.
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Authoring Software

Open Notepad on your PC.

Start > Accessories > Notepad 
[or TextEdit—Mac check preferences for 
TextEdit]
Check Word Wrap: 
Format > Word Wrap
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Interface at a Glance
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SAMPLE CODE:

<html>

<head>

<title></title>

</head>

<body>

<p>Hello World!</p>

</body>

</html>

These are the essential building 
blocks for an HTML page.
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Tag, Element, Attribute, Value
These are the types of markup in HTML…

Element: mostly containers for web
page content, they describe what’s 
inside; some contain text, some 
contain another element, some are empty.

<p>Hello World!</p> 
This is a paragraph element containing text.
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Tag, Element, Attribute, Value

Attribute: many elements can contain 
attributes.

Value: attributes have values, e.g.
<img src=”picture.jpg”

width=”500” height=”400” />.

The element img has an attribute width with a 
value of 500.

Elements are often called “tags.”  
A paragraph “tag,” a body “tag.”
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Exercise 1: Add Title, Add Attributes
and Values, Refresh Browser.

– Save and close hello.html. Open
Notepad again, start a new file , save it
as ex01.html, type the same code as
hello.html, view in browser.

• Add some new code… Add 2 <p>
elements, with attributes and values. Add
text. Add text to the <title> element. Use
tabs to format—indent—the code so it is
readable.
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Exercise 1: Add Title, Add Attributes
and Values, Refresh Browser.

• SAMPLE CODE:
[SEE EXERCISE 1 HANDOUT]

– Save the file!

– Refresh (reload) browser using button
on browser toolbar, View > Reload,
or Ctrl + r.
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Viewing HTML page on Browser. 
How’d It GetThere?

–Internet: a vast network of computer 
networks that transmit data, including email, 
file sharing, streaming media, World Wide 
Web.

– World Wide Web (WWW): sets of
linked files, hypertext documents.

• Hypertext: documents that can be
hyperlinked from one document to
another or many, or within the document.

• Markup: formatting instructions, structure 
of document.
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Viewing HTML page on Browser. 
How’d It GetThere?

– WWW, servers, local computers
• All or some of the files for a web site, or
many websites, can be hosted on
computer configured as a web server.
The files are usually transmitted to a web
server via an FTP connection.
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Viewing HTML page on Browser. 
How’d It GetThere?

• Client-server relationship. A client, like my 
web browser, sends a request (HTTP
request) to a web server for a particular
file, using a URL like http://www.temple.edu.

• Upon receiving the request, the web
server sends this data, via the Internet,
back to the client browser on a computer.
The file may be a web page like hello.html.
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Viewing HTML page on Browser. 
How’d It GetThere?

• Hyperlinks.
This is how web pages connect to one
another. We can follow hyperlinks in a
web page to other pages and documents
on the WWW.

– Local site vs. WWW
• We can create HTML pages and view in a
browser on the file system of our local
computers without Internet or WWW.
They are not public.
• file:///C:/Documents%20and%20Se
ttings/amy/Desktop/ex02.html
• To make the pages public, we upload
them to a server via FTP.
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What is HTML?

HTML is a language for describing web pages.

HTML stands for Hyper Text Markup 
Language

HTML is not a programming language, it is a 
markup language

A markup language is a set of markup tags

HTML uses markup tags to describe web 
pages



Temple University Center City | Spring 2010 | Instructor: Lou Fuiano | www.temple.edu/tucc

Example Explained

The text between <html> and 
</html> describes the web page

The text between <body> and 
</body> is the visible page content

The text between <h1> and </h1> is 
displayed as a heading

The text between <p> and </p> is 
displayed as a paragraph



Temple University Center City | Spring 2010 | Instructor: Lou Fuiano | www.temple.edu/tucc

Exercise 2: Add More Elements.
Nest Elements.

– Save a copy (using File > Save As command) 
of ex01.html with new name, ex02.html.

– Add <div>, a block-level element & 
container, add tabs.

– Add text into <p>. Type it or select from web 
page: www.lipsum.com, or text file.

– Browse to file and view.
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Exercise 2: Add More Elements.
Nest Elements.

– What happens without the <p> elements? 
	 Try it.

– Whitespace in HTML code.

– <em> tag, add and refresh/reload browser to 
view.

SAMPLE CODE:

[SEE EX. 2 HANDOUT]
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DOCTYPE and Encoding.

–Use DOCTYPE
• Use a DOCTYPE declaration at top of web 
page, before anything else.

SAMPLE CODE:

<!DOCTYPE html PUBLIC “-//W3C//
DTD XHTML 1.0 Transitional//
EN”“http://www.w3.org/TR/xhtml1/
DTD/xhtml1-transitional.dtd”>

<html …..[etc]

Copy from text file in Exercises folder.
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DOCTYPE and Encoding.

– Declare Encoding

• Declare the character encoding in the  
head section of the web page.

SAMPLE CODE:

<meta http-equiv=”content-
type”content=”text/html; 
charset=utf-8”>

Copy from text file in Exercises folder.
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DOCTYPE and Encoding.

– And Update the <html> tag

	 (for XHTML only)

SAMPLE CODE:

<html xmlns=”http://www.
w3.org/1999/xhtml” xml:lang=”en” 
lang=”en”>
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Reading for this Section In the text 
by E. Castro, read:

• Introduction

• Chapter 1 – Web Page Building Blocks

• Chapter 2 – Working with Web Page Files

• Chapter 3 – Basic (X)HTML Structure
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Exercise 3: Add Images

– Save copy of ex02.html with new name, 
ex03.html. (File > Save As)

– Insert <img> tag, add src attribute and 
value.

SAMPLE CODE:

<img src=”images playatplate.
jpg” />
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Exercise 3: Add Images

– Change page title, update text inside 
second <p>, use <strong>, replace 
“hello world” paragraph text as in sample 
file.

[SEE EXERCISE 3 HANDOUT]

– Save and view file in your browser.
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Exercise 4: Add links (hyperlinks)to 
other sites.
– Save file ex03.html as ex04.html

	 (File > Save As command).

– Add hyperlink markup to a new paragraph 
of text.

SAMPLE CODE:

<p>

<a href=”http://www.google.
com/”>

Learn more about baseball.

</a></p>
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Exercise 4: Add links (hyperlinks)to 
other sites.
– Add hyperlink markup to an image.

SAMPLE CODE:

<a href=”http://www.espn.com”>

<img src=”images/playatplate.jpg” />

</a>

[SEE EXERCISE 4 HANDOUT]
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What is a URL? Uniform Resource 
Locator.
– Web address consisting of these parts:

scheme (http), 
server name (www.site com),
path (/baseball/),
file (heroes.html)
http://www.site.com/baseball/heroes.html

– Absolute URLs (Exercise 4).
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Exercise 5: Add Relative Links

– Create new HTML document: ex05.html, 
use new photo.

– Add relative link to ex04.html; browser 
looks in the same folder (as the current file) 
for file that’s requested.

SAMPLE CODE:

<p><a href=”ex04.html”>View 
previous page.</a></p>

– Test link in browser.
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Exercise 5: Add Relative Links

– Move HTML page to new folder.

Update the hyperlink…

• Create a new folder inside your HTML 
Exercises folder. File > New > Folder

• Name it level2.

• Drag ex04.html into the folder.

• Test in browser—does the link in ex05.
html still work?
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Exercise 5: Add Relative Links

• Update the href attribute in ex05.html to 
include the new folder in file path.

SAMPLE CODE:

<p>  
<a href=”level2/ex04.html”>View 
previous page.</a></p>

– Refresh the browser & try link again.

– Image not visible now? Open ex04.html 
and update path to the image.

– Close this file when finished exercise
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Exercise 6: Navigation & Lists, Getting 
from Page to Page Consistently.

– Create new HTML document, ex06.html, 
<title>List Page</title>

– Include 2 <div> elements.

– Nest a list, inside first <div>, to use as 
navigation.

<ul> = unordered list

<li> = list item

This is an unordered list. Browsers will

usually render it with bullets.
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Exercise 6: Navigation & Lists, Getting 
from Page to Page Consistently.

CODE SAMPLE:

<div>

<ul>

<li>Patriots</li>

<li>Giants</li>

<li>Eagles</li>

<li>Jets</li>

</ul>

</div>
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Exercise 6: Navigation & Lists, Getting 
from Page to Page Consistently.

– Create some categories using your own 
text within list items, as above.

– View in browser.

– Copy & paste the list; change <ul> to 
<ol> to view an ordered list. Browser 
automatically numbers the list items.

– Insert your own text in second <div>.

[SEE EXERCISE 6 HANDOUT]
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Exercise 7: Creating a Template: A 
Reusable Page
– Document from Ex. 6 can become a 
template page—copies can become multiple 
pages with common organization of the 
elements; use “File > Save As” command to 
save ex06.html as ex07.html.

– Add <h1> and <h2> elements.

– Remove the entire <ol>.
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Exercise 7: Creating a Template: A 
Reusable Page
– Add new paragraph containing image.

– Update text as in handout.

– <br />, line break element.

– This file will be used as the template file for 
Exercise 8.

[SEE EXERCISE 7 HANDOUT]
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Reading for this Section  
In the text by E. Castro, read:
• Chapter 6 – Links

• Chapter 5 - Images

• Chapter 15 – Lists (for now, skip any info 
related to styles or style sheets)
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About Planning and Building a Site

a. What is the site’s content?

b. Section content into major categories.

c. Make a map or diagram of site.

Paper, word processor, Excel, Visio, white 
board, Illustrator, post-it notes etc.
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About Planning and Building a Site

Example 1:

Each box represents a category of content; it 
might be a page or a section of the website.

Note the hierarchy, more than 1 level of 
content.

[see graphic next slide]
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About Planning and Building a Site

PRODUCTS

RETAILWHOLESALE

INTERNA-
TIONAL

SECURITY

NEWS

MONTHLY ARCHIVES

CONTACT

HOME

SERVICE

AFFILIATES
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About Planning and Building a Site

PRODUCTS
index.html

RETAIL
retail.html

WHOLESALE
wholesale.html

INTERNA-
TIONAL
index.html

SECURITY
security.html

NEWS
index.html

MONTHLY
monthy.html

ARCHIVES
archives.html

CONTACT
index.html

HOME
index.html

SERVICE
index.html

AFFILIATES
affiliates.html



Temple University Center City | Spring 2010 | Instructor: Lou Fuiano | www.temple.edu/tucc

About Planning and Building a Site

index.html
- products (folder)

index.html
wholesale.html
retail.html

- contact (folder)
index.html

- services (folder)
index.html
affiliates.html

- international (folder)
index.html
security.html

Web designer /
web developer can
create these
folders and files􀃆
There is usually a default 
or
index file in each folder
(directory), if missing, the
viewer may possibly see 
a list
of all the files instead of a
page!
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About Planning and Building a Site
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About Planning and Building a Site


